This config is for a Version 7 ROS.
xxxxxxxxxx
/ip address
add address=192.168.0.26/24 interface=ether2 network=192.168.0.0
xxxxxxxxxx
/ip route
add disabled=no distance=1 dst-address=66.248.232.142 gateway=192.168.0.1
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wireguard1 pref-src="" routing-table=main suppress-hw-offload=no
x
/interface bridge add name=bridge1
/interface/bridge/port
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=wireguard1
xxxxxxxxxx
/ip/address
add address=44.31.0.129/29 interface=bridge1 network=44.31.0.224
x
/interface wireguard
add listen-port=13231 mtu=1420 name=wireguard1 private-key="oMWYma35a;lkHJ()_j3j098s16J/H/+NNRKdUM=" public-key="Vk3Lgv3rcFMdhyQIadf98&KJh3a80Im8fs9xI="
xxxxxxxxxx
/interface wireguard
peers add allowed-address=0.0.0.0/0 endpoint-address=66.248.232.142 endpoint-port=51820 interface=wireguard1 public-key="hFXydv5SUT/1iIeR8PIqaJwc5VCbyVjm4bSXSc72skA="
/ip address
add address=44.190.41.46 interface=wireguard1 network=44.190.41.46
/ip firewall mangle
add action=change-mss chain=forward new-mss=clamp-to-pmtu passthrough=yes protocol=tcp tcp-flags=syn
xxxxxxxxxx
/routing/bgp/connection
add name=portal-bgp **local**.address=44.190.41.46 as=64516 **remote**.address=44.190.41.1 **remote**.as=64513 **local**.port=179 **local**.ttl=200 **local**.role=ebgp-peer routing-table=main router-id=44. 190.41.46 nexthop-choice=default multihop=yes address-families=ip **input**.ignore-as-path-len=no **output**.network=bgp-networks connect=yes listen=yes
xxxxxxxxxx
/ip/firewall/address-list
add list=bgp-networks address=66.248.233.192/26
/ip/route/ add dst-address=66.248.233.192/26
xxxxxxxxxx
/ip pool
add name=dhcp_pool0 ranges=66.248.233.193-66.248.233.253
/ip dhcp-server
add address-pool=dhcp_pool0 interface=bridge1 name=dhcp1
/ip dhcp-server network
add address=66.248.233.192/26 dns-server=8.8.8.8 domain=airgapped.io gateway=66.248.233.254 ntp-server=44.190.41.123
/ip dns
set allow-remote-requests=yes servers=8.8.8.8